
Chapter 1: Getting Started 

Maya Interface 

As you can edit the interface to your own preferences, we will need to ensure the correlation 

between this book and what you see on the interface in front of you. To bring Maya back to its 

default settings navigate to Window > Settings/Preferences > Preferences (In the dialogue 

box) Edit > Restore Default Settings. 

1. Main Menu Bar 
2. Status Line  
3. Maya Menu Set 
4. Global Controller/Manipulator 
5. Tools 
6. Workspace  
7. Workspace Pre-sets 
8. Time slider 
9. Range Slider 
10. Command Line  
11. Help Line 
12. Channel Box 
13. Layer Editor 
14. Playback Controls 
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Maya Menu System 

By default Maya opens up on the Animation Menu Set, this will present you with the following 

options: 

 

 

 

 

 

By selecting from the menu set it changes all icons apart from the first 7 (which are constant). 

This means whatever stage you are undertaking you have to ensure you’re in the correct menu 

set, because you may find yourself looking for a tool you cannot access. 

The below will illustrate examples of available options when selecting the different menu sets 

and the variety of tools that are available: 

Animation:  

 

 

 

Polygons: 

 

 

 

Surface: 

 

 

  



Chapter 1: Getting Started 

Menu Shortcuts 

F2 – Animation Menu F3 – Polygons Menu  F4 – Surfaces Menu Set   

F5 – Dynamics Menu  F6 – Rendering  

Overview of Processes and Terminologies  

Workflow 

Maya workflows may vary between you, so don’t be alarmed if you end up doing things a little 

differently. Workflows are the order in which you would go through a project, but certain steps 

may be missed entirely depending on your goal. Our best practice would go something like 

this: 

1. Concept Art and Storyboarding 

Concept art is the first stage where any character is born and should always be used to relate 

back to during the design stages. Storyboarding is a sequence of illustrations with the sole 

purpose to pre-visualise your final animation.  

2. Modelling 

The 3 very different geometry types (Polygons, NURBS & Sub-Divisional Surfaces) each have 

their own unique attributes that once utilized will enable you to create models with ease. Each 

type can be converted into one another at any point throughout the modelling process and is 

often useful to do so as they each have key advantages that once utilized could lead to 

increased productivity.  

Construction History: Every action you do will create a footprint how many sequential 

footprints that are recorded (i.e. how many times you can press ctrl-z) are editable within Maya 

preferences, the default is set to 50 actions. However, history is applied to a specific object 

every time something is changed, be it moved, stretched or interacted with by another. This 

enables you to tweak settings that have been previously applied, creating a kind of dynamic 

undo ability. It does however take up additional memory and unfortunately the more history 

that ties onto an object the more likely things will go wrong at later stages such as rigging. 

Therefore, once you’re satisfied with your model and before moving onto the next stage save 

your file with the entire history (optional), delete the history File > Delete by Type > History 

and save using the sequential naming structure discussed on page 41. 
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3. Textures & Shading 

Shaders are what we use to provide our models with colour; contributing to their final 

appearance. Early on, you will most probably add default colours to objects but as your 

understanding increases along with your knowledge of the various Shader types, you will be 

able to create more elaborate and realistic effects depending on your requirements. Texture 

mapping adds additional levels to the standard Shader options; it allows you to import image 

files on various attributes allowing the manipulation of effects such as transparency or bump. 

4. Lighting  

There are various types of lighting used within Maya and arranging lights within your scene in 

order to complement models can often be overlooked by individuals or even missed off all 

together. Taking some time to learn the methodologies attached to this section will pay 

dividends when it comes time to render. 

5. Rigging | Binding 

Joints are forms of hierarchies, and once a skeleton (rig) has been created it allows you to 

bind with geometry in order to create deformations. They can be used to perform actions such 

as page turns in a book just as well as creating a fully functional character.  

This section can also include: 

 Painting Weights 

 Creating Blendshapes  

 Hair and Fur Rigs 
 

Once your character is bound to the rig you will be able to facilitate movement. 

6. Animating 

This is where you can breathe life into your character. Traditionally, you will begin with key 

framing, however you’ll soon learn this isn’t the only way to meet your goals. 

7. Rendering 

Quintessentially, rendering is the process of compiling all (or selected) aspects of your scene 

into one. By default it will take into account all the characteristics such as applied textures, 

lighting, shadows, reflections, and transparency.   
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Transform Hierarchy and Relationships 

In Maya an objects relationship to another creates what is known as the transform hierarchy. 

A parent/child relationship would link attributes such as translate, rotate, and scale. These 

attributes can be linked to its parent, its parents’ parent and so on and so forth.  

Scripting 

Almost every aspect of Maya can be manipulated using MEL script, based on C++. This allows 

a user to directly interact with Maya and write their own scripts. This is particularly aimed at 

technical animation and rigging, for example moving a large number of objects with a random 

variable, or automating a long drawn out task to be executed at the press of a button. 

Maya has recently also added support for Python, a more powerful and cross compatible 

language, however, I would recommend this only to programmers who are already 

comfortable with Python as Maya will not break down the commands for you to reference like 

it does with MEL.  

We will delve into an introduction to MEL scripting a little later and as part of this book, you 

will be eligible for a free Scripts via the Spotlight Studios website. 
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Channels Box and Nodes 

The channel box is located on the right hand side of your screen 

and provides access to the most commonly used attributes. It has 

a coloured key (opposite) for quick reference illustrating if an 

attribute has been keyed, locked, or linked with another. The 

nodes on the right hand side (RHS) are split into three sections:  

 Transform: General positioning information, affected if 

you translate rotate or scale your model. 

 Shape: Holds all generic information to do with the overall 

shape appearance. 

 Input: Generic creational input node, holds information on 

height, width and length as well as options such as how 

many subdivisions or sections, an item will have. 

 

Note: The input node can only be used for initial modifications as 

later usage will result in anomalies if you have edited your shape 

in any way. Should you delete the history at any point (on your model) this option be removed. 
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Using 

the Hot-

Box 

The Hot-

Box is 

another 

often 

untouched 

tool that we 

find 

incredibly 

useful. 

Holding 

down the 

Space Bar 

in any of 

you 

viewport 

windows will give you a series of white menus that duplicate the menu structure of Maya. This 

saves time changing menu modes and gives you all of Maya’s controls at your fingertips; you 

can use this as well as, or instead of the standard menu, and can also display pane specific 

and custom menus. 

The Hot-Box also gives you quick access to difference layouts, masks, UI elements etc. 

 

 

 

 

 

 

 

 

Connection Colour Description 

Muted Animation Brown The attribute has been animated but it 

has been muted, therefore playback 

will not commence. 

Constraint Blue This attribute is linked to an attribute 

of another. 

Locked Grey Un-editable whilst in this state. 

Non-keyable Grey (Light) Cannot be animated. 

Blended Green Blended with another attribute. 

Keyframed Orange A keyframe has been added to this 

attribute. 

Expression Control Purple An expression regulates this attribute. 

Connected / 

Dynamic 

Yellow Shares identical values as another, or 

is dynamically influenced. 
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Note: The hierarchical structure correlates directly from the menu at the top left (discussed 

earlier) and the Hot-Box controls that appear when pressing the space bar. 
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Using the Menus efficiently 

Wherever possible, get into the habit of using the small option box on the right hand side of 

the dropdown menu, even for 

mundane tasks like creating a 

cube. This provides access to an 

additional dialogue box, thus 

allowing you to see additional 

parameters, whilst ensuring the 

default settings are applied, 

unless you require otherwise. 

Many of these settings or 

parameters can be altered at a 

later point using the Attribute 

Editor or Channel Box so if you 

do forget initially this can be rectified. 

Maya provides the ability to “tear off” nearly all menus and sub-menus to give you instant 

access to certain tools. To do this click on the dotted line at the top of a drop-down menu and 

this will create a pop-out version, very useful for circumstances such as Painting Weights. 

Marking Menus 

These are selection sensitive, which means dependent on the 

item in question the menu will adapt accordingly. To access a 

marking menu hold down your Right Mouse Button (RMB) on 

an object; then by dragging it around and interactive line will 

emanate from the centre to illustrate what option you currently 

have selected, by releasing the RMB you will select the 

relevant option. 
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Working Within a 3D Environment 

If you are not accustomed with 3D 

packages you should familiarise with 

their basic workspace principles.  As 

you would expect the three 

dimensions are represented by axes 

which are: 

Length  (X – Red) 

Height  (Y – Green) 

Width  (Z – Blue) 

 

These axes will always serve as you reference points and will be given specific co-ordinates 

based on the objects location, the default location of an object being 0,0,0. 

  

Manipulators 

There are three main types of manipulators that are used constantly throughout a project and 

these are: 

    Translate      Rotate   Scale 

  Shortcut: w   Shortcut: e          Shortcut: r 

 

 

 

 

 

 

The manipulator handles that appear when the relevant tool is used are self-explanatory, 

nonetheless we recommend using them a little to fully understand their usability. Once you 

begin to use keyboard shortcuts (such as those highlighted above) it will considerably speed 

up your workflow. 
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Universal Manipulator 

This tool is a combination of all three of the 

above actions and allows for simultaneous 

manipulation without the need to change tools. 

Some users find this quicker and useful others 

prefer to edit each aspect individually ensuring 

errors are not made by selecting the wrong 

manipulation type. 

 

Soft Select 

Checking this box within the tool settings 

pane (or pressing 'b') for your selected 

manipulator (translate, rotate or scale) 

allows you to add a gradual falloff from the 

selected points. When active, you are 

presented with a colour coded selection 

area (Yellow / Red / Black) indicating the influence that will be affected. This is useful to give 

smooth deformation of an object, especially useful in creating and modifying organic shapes 

such as faces. 

 

Note: This is not to be confused with the Soft-Modification tool which we will get too later in 

the deformers section. 
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Workspace and Cameras 

In order for you to be able to view a scene, you will always be looking through a camera. There 

are two main camera types in Maya, these are: 

1. Perspective – These cameras provide depth illustrating that objects further away from the 

camera appear smaller than those closer to it, just as if you perceived the objects through 

a camera lens. 

2. Orthographic – These will not add perspective in any way but will allow parallel viewing 

from any side, or the top of a scene. This is usual for comparing the actual length of various 

parts of a shape as their displayed size is irrespective of their distance from the viewer. 

 

 

 

 

 

 

 

 

 

 

Switching Cameras / Workspace 

By default you will see the (top right) perspective camera view screen upon launching Maya. 

To alternate views, press the spacebar to launch this screen, and simply ensure the mouse 

pointer is hovering over the workspace you require and tap the space bar again to select an 

alternate view. 

  

Perspectiv

e 

Orthographi
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Navigation 

The majority of you will be using a mouse and keyboard to navigate around within Maya, there 

is another popular form of navigation which is the graphics tablet, which people will often 

customise to their own personal preference once they have had experience within Maya. If 

you are a first time user we would recommend the traditional keyboard and mouse at this 

point, but feel free to experiment in the near future. 

Camera movement and control (Standard 3 button mouse):  

 Left Mouse Button (LMB) - Selection tool. 

 Alt + LMB - Rotates camera. 

 Right mouse button (RMB) – Marking Menu. 

 Alt + RMB - Dolly In and out (not zoom as it actually moves the camera). 

 Middle Mouse Button (MMB) Scroll - zoom (changes focal length). 

 Alt + MMB – Panning, horizontal or vertical depending on mouse movement. 

1 or 2 Button Mouse controls 

For Mac and Laptop users, we would highly recommend purchasing a 3 button mouse (Mac 

OSX is configured to work with them out of the box). On a Mac the Option button replaces Alt, 

and the Command (Apple) key will replace the windows Ctrl key. 

However, if you are set on not having a 3 button mouse you can navigate to preferences > 

Interface > Devices and you can toggle between one, two, or three button mouse controls with 

or without the option of a scroll wheel.  

Creating a Personalised shelf 

The shelf is an invaluable tool at your disposal. Essentially it is a customisable shortcut bar to 

give you access to all of your favourite tools or scripts quickly and easily. Maya comes set up 

with a number of preset shelves for different areas of animation, such as Polygons, Rendering 

and nCloth. 

These provided a very useful basis for getting started, but it becomes much more valuable 

when you start creating your own shelves. You can change shelves by selecting the tab, or if 

you have a lot then you can click and hold the tab on the far left and select it from a drop down 

menu. The button under that gives you a menu where you can create, delete, load, save and 

modify the hierarchy of your shelves.  
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Create a new shelf and give it a name. To add a button to a shelf you simple shift-ctrl-click the 

menu item, for example, to add to create poly button, go to Menu > Create > Polygon > 

Primitives and Shift-Ctrl-LMB the Cube option box.  

You will see the button added to the end of the shelf. You can re-arrange shelf buttons by 

middle click and dragging the button, and remove shelf buttons by dragging them to the bin 

icon on the right hand corner. Now click the button and the Cube Create tool will be activated 

and the tool settings window will also appear. 

Example Shelf 

 

 

 

From Left to Right: Delete by type History, Centre Pivot, Freeze Transformations, Show All, 

Split Polygon Tool, Merge Vertices/Edges, Insert Edge loop, Select Continuous Edge, 

Extrude, Bend, and Sculpt Geometry Tool. 
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Introduction to the Outliner 

The outliner is one of the key areas when it comes to the organisation of your scene. Maya 

represents every object you create as a node (as well as a few defaults), these nodes can 

then be organised within the outliner to ensure organisation and continuity is kept throughout. 

This feature allows you to re-arrange the nodes into groups, thus creating hierarchies enabling 

them to be 

controlled as 

one. You may 

also use this to 

create and edit 

parent/child 

relationships 

explained 

previously. 

 

 

This is how the outliner appears by default when there 

is no other geometry in your scene. Throughout the 

modelling process it is good practice to either keep the 

outliner open (dependent on your available screen 

space) or to refer back to it at regular intervals. We will 

be referencing the outliner throughout the book thus 

gradually introducing you to new aspects as a when you 

need them. 
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Outliner Hierarchy 

The outliner hierarchy is structured as parents and 

children and the transform manipulations are passed 

from parent to child and so on. For example, if a parent 

node ‘A’ is moved along the X-axis by 2 then the child 

‘B’ will also move along the X-axis by 2 and so will it’s 

child, ‘C’. 

One parent can have many children, a child can become a parent but will only ever have one, 

although can be influenced by its parents parent; known to the child as a grandparent node. 

Viewing your Scene 

Smooth Shaded: Shading > Smooth Shade All - This enables you to display the items in your 

scene as solid objects, if you have assigned colours they will be displayed accordingly (they 

can be disabled by selecting, Shading > Use Default Material very good for gauging what your 

image will render like. 

Wireframe: Shading > Wireframe - Often used when editing vertices, enabling you to see the 

individual make-up of an item, whether this be in poly’s, NURBS or sub-D’s. 

Wireframe on Shaded: Shading > Wireframe on Shaded - A combination of the two shading 

options above. You’re able to see the make-up of an object whilst keeping it in solid form, very 

useful when tidying up geometry.  

X-Ray: Shading > X-Ray - As you will probably guess this is gives you a semi-transparent 

view of any object within the scene.  

Variations: 

In the panel options there 

are various Shading options 

you can apply, the ones 

above are the most 

commonly used but there 

are others, so have a play 

and see what suits you. 
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Scripting 

Scripting is using code (specifically MEL script) to directly interact with Maya. This can involve 

everything from automating tasks to tool development. 

MEL (Maya Embedded Language) 

For every action a piece of MEL code is created and implemented, you can use this to write 

scripts or execute simple commands. The image accompanying this text illustrates how the 

creation of a polygon cube generates MEL code and if we were to highlight the code in the top 

section, copy it to the bottom section and execute the command we would be presented with 

a second polygon cube. We will delve into MEL scripting a little later in the book and will 

introduce you to some of our scripts (available from our website) which you are welcome to 

use at your discretion. 

Python 

Some programmers who migrate over to Maya will be able to implement their own tools using 

this coding language. Maya has only allowed the default built-in commands to be accessed 

through Python scripting. 
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Hot Keys 

Note: Maya is case sensitive so if you are getting an unexpected action or nothing at all ensure Caps 
Lock is off. Also the Option key on a Mac replicates Alt.  

Menu Selection 

Hotkey Action 

F1 Help 

F2 Animation Menu Set 

F3 Polygons Menu Set 

F4 Surfaces Menu Set 

F5 Dynamic Menu Set 

F6 Rendering Menu Set 

F8 Toggle Component Type / Object Type Mode 

Display 

Hotkey Action 

1 Low Polygon (base) 

2 Medium Polygon (Combination of base and smooth) 

3 High Quality Polygon (Smooth Preview) 

4 Wireframe 

5 Shaded 

6 Textured 

7 Use Scene Lighting 

Alt-b  Cycle Workspace Background Colour 

Space Hotbox Controls 

Ctrl-h Hide Selection (Display > Hide > Hide Selection) 

Hotkey Action 
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Ctrl-Shift-H Show Last Hidden (Display > Show > Show Last 

Hidden) 

Alt-h  Hide Unselected (Display > Hide > Hide unselected 

Objects) 

Shift-I Isolate (Show > Isolated > View Selected) 

Shift-> Increase Vertices Selection  

Shift-< Decrease Vertices Selection 

 

Navigation 

Hotkey Action 

Alt-LMB Tumble / Rotate 

Alt-MMB  Track / Pan 

Alt-RMB Dolly / Zoom 

 

Moving Objects 

Hotkey Action 

Alt-Up Move Up One Pixel 

Alt-Down Move Down One Pixel 

Alt-Left Move Left One Pixel 

Alt-Right  Move Right One Pixel 

Tool Operations 

Hotkey Action 

Return Complete current action 

Insert Edit Pivot Point 

Q Select Tool 
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Hotkey Action 

W Translate (Move) Tool 

E Rotate Tool 

R Scale Tool 

T Show Manipulator Tool 

Y Select Last Used Tool 

+ Increase Manipulator Handle Size 

- Decrease Manipulator Handle Size 

Snapping 

Hotkey Action 

C Snap to Curve 

X Snap to Grid 

V Snap to Point 

Editing 

Hotkey Action 

Ctrl-c Copy (Edit > Copy) 

Ctrl-d Duplicate (Edit > Duplicate) 

Ctrl-Shift-D Duplicate Special (Edit > Duplicate Special) 

g Repeat Last Action 

Ctrl-g Group (Edit > Group) 

p  Parent (Edit > Parent) 

Shift-P Unparent (Edit >Unparent) 

Ctrl-s Save 
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Hotkey Action 

Ctrl-v Paste (Edit > Paste) 

Ctrl-x Cut (Edit > Cut) 

Ctrl-z Undo (Edit > Undo) 

Shift-Z Redo (Edit > Redo) 

Animation Operations 

Hotkey Action 

s Set Key (Animate > Set Key) 

Shift-E Set Key for Rotate 

Shift-R Set Key for Scale 

Shift-W Set Key for Translate 

 

Note: To edit or create a new Hotkey navigate to Window > Settings / Preferences > Hotkey 

Editor 
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Scene Setup 

Creating a New Project 

Upon launching Maya 

the first thing you should do is to set 

a Project. This essentially tells Maya 

how to organise a local folder to 

distribute scene files, textures, and 

images as well as saving the 

workspace information. This allows for easy integration within the project and allows the 

project to be distributed while maintaining links to assets, textures and other referenced scene 

data. 

This ultimately means working from multiple workstations is effortless as you can just copy the 

project folder to a different location (or load the project from a network location) and images 

etc. will be referenced relative to the project location rather than an absolute path such as 

C:\Documents and Settings\My Pictures\. 
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To create a New Project click, File > Project > New, then enter a project name and click use 

defaults at the bottom (recommended). If you do however wish to fill them in manually you can 

write your folder names you require in the relevant empty fields. After either option you will 

need to select Create, to finalise the process. 

Setting an Existing Project 

Upon creating 

a project folder or 

alternating between 

various projects you will 

need to select File > 

Project > Set and select the appropriate project file (remembering Maya looks at this folder for 

references) 
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Useful Notes 

Naming Conventions 

It is extremely important to have good naming 

conventions and group structure when you are 

building your scene. It is a practice we would 

recommend you get into a habit early on so that it 

becomes second nature. The advantage of this is 

twofold; it makes it easy to find a specific object (you 

can simple type the prefix into the Outliner or your 

Select by name field) and it also helps minimise 

grouping problems such as double transformation. On 

the right is an example of an asset we have created 

(the chandelier from our saloon scene) to give you an 

example of good naming and grouping practices. 

It is worth noting that Maya likes objects to start with 

a lower case letter and for multiple words to be 

defined by capitalising the first Letter. For example 

Maya will read “oneTwoThree” as “One Two Three”. 
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Save Sequentially 

You should structure your saved files in generations, so that if you need to return to a previous 

point for whatever reason, or you incur file corruption, only the time between file generations 

is lost. This can be done daily, weekly, or for every save generation depending on how 

important the project is, how much the project changes and, ultimately, how much space you 

have available. 

The simplest method is to simply use Maya’s built in incremental save feature. Clicking the 

box next to File > Save will bring up a few options, turning the feature on and off, and also 

allowing you to automatically limit the number of generations that is kept on the computer at 

any one time. 

An alternative manual method is to simply number each File <Scene_01_001.mb, 

Scene_01_002.mb etc.> alternatively if you’re feeling adventurous you could incorporate the 

date, time, place of creation (home/labs/work) etc. 

It is also worth mentioning here, that it is important to back up your work to an external drive 

or an online storage alternative as often as you feel necessary. 

Hiding Un-Used Items to free up real-estate: 

You can hide nearly every part of Maya’s UI in order to dedicate a greater portion of the screen 

to the viewport. Everything is entirely subjective to an individual’s way of working, but 

combined with the hotbox this can be a very powerful and visual way to work. 

The Outliner is your friend: 

Everyone works in different ways, but in our experience we have found that working in a very 

‘clean’ and organised way tends to make the process much faster and more efficient in the 

long run, this makes problems that crop up much easier to fix and group work a lot less painful. 

The Outliner is simply a Hierarchal list of your scene, like a simplified Hypergraph. You can 

select and move objects around between hierarchal levels and provides a very easy way of 

renaming (double click) and organising (MMB and drag objects) your scene. (Pg 32 for more 

details) 
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Display Layers 

You can use display layers to limit what is visible and selectable in your scene. These work in 

a very similar way to Photoshop layers. 

For each display layer, objects that you put in the layer can act as normal, be referenced, or 

become a template. 

When a layer is set to reference, the objects will appear as they would normally in the viewport, 

but they will not be selectable. This is very useful if you have background objects or geometry 

that may get in the way of you selecting your controls. 

When a layer is set to template, the objects are neither selectable nor are they renderable. 

They will show up in your viewport, but only in a greyed out wireframe. This could be used to 

either limit the clutter on the screen (while still showing the objects’ locations) or to show the 

position of an animated proxy object while you animate the main character over the top. 

Large / Group Projects / Referencing 

When working on large or group projects, organisation becomes even more important, and a 

clear file naming and storage should be designed and maintained very early on. 

The more ‘stuff’ in your scene, the slower Maya will run and the more difficult it becomes to 

navigate, select and modify parts of the project. You may also have the same content in 

different scene files, what happens if you need to change the main characters dress? You can 

help to get around this to some extent managing layers, but it doesn’t quite solve the problem. 

The best way to properly address this kind of issue is to Reference in your different parts. This 

means that at the top level, you will not actually have any objects in the scene, but rather be 

changing the values of the objects you are referencing. This means that at any stage you can 

go back and edit the referenced objects without worrying about what you have used the 

objects in. This also means that in some cases you can animate a character in a scene whilst 

other people continue to work on the files, each time you open the scene or reload the 

references everything will be updated to the latest versions, but any changes you have made 

within your animation will stay the same. 

With specific reference to speeding your scene up, you can animate your character to a very 

basic 'proxy' environment, and then when you have completed the animation, you can unload 

the environment and save the file as an animated asset. When you are ready to put the scene 

together, referencing this file will automatically follow through and also reference in the original 

character model, too. 
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This kind of structure, as long as it is well managed allows you to be much more flexible with 

your animation. 

To import an asset as a reference, simply click File > Create Reference and choose the file 

you wish to reference. You can use the Reference Editor (next button down) to manage and 

reload existing references. 

It is worth noting that the organisational structure of the asset will stay unchanged, and 

referenced nodes cannot be moved or deleted. For this reason, it is strongly recommended 

by us that your assets always stem from a single named Node. 


