
Chapter 3: Texturing 

AH | Preparing an object for a Material 

UV Unwrapping Basics 

UVs are a series of 2D points that reside within the vertex component information. In essence 

they provide co-ordinates that allow us to map a 2D texture onto a 3D image. UV’s are always 

done after the Modelling process as further manipulation of an objects vertices will manipulate 

the UV’s also. 

Mapping UV’s 

There is no glossing up this section as it’s probably one of the most boring and tedious parts 

of texturing but also pivitol to your success. If you plan on spending some time getting that 

pefect texture you are going to want your Model to be prepared correctly. 

I’m going to make a very quick low polygon that I would like 

to be a wooden window frame. 

For reference I made a polygon cube,  sized it accordingly, 

deleted the front and back face, extruded all the side faces 

then deleted the faces I selected to do the extrude). 

Now as this is a wooden window frame I am going to want my 

wood grain to flow with the shape as if the were created out 

of a piece of wood (seems logical). 

Next it’s time to test the object with a chequered texture 

(Right click and drag down to assign favourite material > 

Lambert > Colour □ > Checker 

I’m sure you will agree that’s not what you expected to 

happen. So it 

needs a little 

work to ensure 

the texture is 

correctly spread out over your objectd.  

 

So to find out why we need to take a look at the UV 

Texture Editor Polygons (menu set) > Edit UV’s > UV 

Texture Editor  
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The images to the left are of the same thing only with the display 

image on (and dimmed) or off (to toggle these option look for a 

picture of a face within the UV Texture editor). From here its very 

obvious why the centre section is the only aspect that has a 

texture, because it’s the only four sides we can see. 

From here we 

are going to 

select Create UV’s >Automatic Mapping 

instanstly you will see your texture map all over 

your image and something a little more familiar 

looking within your UV Texture Editor. You will 

notice some sections are more closely packed 

with the texture then others. 

 

You can spend a little time cleaning things up to make them 

more accurate, and depending on how fundamental they will 

be to your shot will depend on the level of accuracy you may 

require.  

To move the UV’s you have to right click and drag to UV, then 

the same principles apply as when you are in the workspace 

(move, scale and rotate). You 

can separate or join edges and/or UV’s, or snap them to one 

another by holding the “v” key. Don’t’ be afraid of overlaying 

one area with another if you want the same bit of the texture to 

be applied (i.e. both sides of 

an object). 

 

Once you are generally happy with the layout you can either make a generic texture and import 

it or you can save an image to use as a reference in Photoshop (or equivalent) by going to 

Polygons > UV snapshot. Adjust the sliders accordingly but as a general rule textures should 

be square and are usually 1024 or 2048 (again dependant on the image quality you require). 

We will continue with wooden texture creation a little later on.  
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AH | Transferring UV Attributes 

You may come across circumstances where you have to transfer the UV’s of one 

object to an identical counterpart. 

I’m just going to be using a simple wood plank in 

this example: 

I would like to transfer the UV’s of the object on the left to the UV’s of the object 

on the right. 

Select the source object (left), then shift select the target (right). 

Within the polygon 

menu set select 

Mesh > Transfer 

Attributes □ and 

apply the following 

settings.  

 

With both objects 

still selected you will see that the UVs appear like one set 

because they are now exactly aligned. 

Note: Until you clear your history your geometry will inherit all changes made to the source. 
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AH | Overview of Maya Materials 

Understanding the fundamentals of Materials (Window > Rendering Editors > Hypershade) is 

important and should not be overlooked, therefore when you do have to create a material it 

will ultimately replicate what you initially envisioned. 

Diffuse: The spread or distribution of light across a surface 

Specular: Characteristics referring to the shaders reflective capabilities 

Lambert: Most Commonly used for matt surfaces such as wallpaper 

There is no specular highlight on this shader as the light is diffused across the surface of the 

material in every direction. 

Blinn: Often used for glossy/metallic surfaces such as chrome 

The surface of a Blinn diffuses specular a lot more gradually than that of a Phong. Eccentricity 

controls highlight size giving a more versatile surface that can be easily adapted to various 

materials. 

Phong: Often used to replicate metals, plastics and glass 

This shader has a very definitive focal point. Cosine Power (Low value big highlight) affects 

the “Shininess” in turn leading to a specular highlight that drops off sharply. Less complex than 

a Blinn as it fails to account for angular changes when looking at the specularity. 

Phong E Shader: Similar to above, and are used for metals, plastics and glass 

It provides the user with more control over using two attributes being Roughness and Highlight 

Size together to affect the “shininess” whilst maintaining a sharper appearance than Blinn.  

Ramp: Very often used for editing other shader attributes 

Enables transition between multiple colours on a single shader. Commonly used to edit the 

appearance of other shaders; enabling the adjustment of attributes such as transparency, 

specular highlights, incidence, incandescence, light, reflectivity and ambient occlusion.  
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Layered: Often used when a material is composed of multiple components 

Enables different textures types to be applied to the same piece of geometry.  For the more 

advanced user it allows for shader stacking which can produce some very elaborate and 

spectacular results. 

Anisotropic Shader: Often used for blemished objects such as crumpled foil 

Used for materials where light reflectivity differs according to direction as it will reflect 

asymmetrically. 

AH | Hypershade 

Ways to Access the Hypershade Menu  

 Window > Rendering Editors > Hypershade 

 Inside a Panel select Panels > Panel > Hypershade 

 Hotbox: LMB click underneath all other options and drag left 

 

 

 

 

 

 

 

 

 

 

Maya’s Hypershade provides you with the ability to quickly create, edit and delete render 

nodes. If you’re thinking “What is a render node?” then the simple answer is that they are 

iconized characteristics of elements within Maya, such as Materials, Textures, Lights, Utilities, 

and Cameras. Below you will see the default Hypershade menu and what there functions are. 
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Hypershade Tabs & Nodes (Left Column) 

The tabs and structure are organized so you can easily access the specific node you require. 

One of the few ways to create nodes is directly within the Hypershade, to do this you firstly 

click on any heading node under the “create” section then click the appropriate node (right 

hand column) to add it to the work area. 

Hypershade Menu 

As within most aspects of Maya you can create customised tabs and choose a layout of your 

choice. Many of the menu options are self-explanatory but we will be covering the more 

ambiguous ones later in this section. 

Hypershade Work Area 

As you might imagine the “Work Area” tab is where you can create relationships, or edit 

attributes and characteristics of multiple nodes at any one given time. Although designed for 

building shaders, rigging techniques also use this area. 

Navigation and Controls within the Hypershade 

You can navigate and access features within the Hypershade menu the same way in which 

you do within your scene. 

Hot Key  Action 

Alt + LMB   Tumble / Rotate 

Alt + MMB  Track / Pan 

Alt + RMB   Dolly / Zoom 

A   Frame all Nodes 

F    Frame an individual node 

Ctrl + A   Attribute Editor 

How to Work on a Texture Node 

MMB click and drag from the top window to bottom (Workspace).  

Clearing the Workspace  

Navigate to the icon bar and click on the clear graph Button which resembles an eraser tool 

this will (like eraser tool), the nodes will not be deleted just removed from the workspace area. 

Renaming a Node 

On the node, right click and drag down to rename. 
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Grouping 

Like within the main scene you 

can create layers to help organise 

your scene, the same principle 

applies to the textures only 

instead of layers they use bins. 

Within the Bins Tab you can 

create an empty bin, create a bin 

from selected or select all 

unsorted items. 

Removing a node from the bin is 

just as easy. Select the node, right 

click on the bin and select remove 

selected node. 

AH | Assigning a Material to an Object 

There are a few ways to assign a texture to an object so which ever method you use will have 

the same effect. 

 Open the Hypershade > Click on the Material > 

MMB drag from the texture/shader node onto 

your object 

 Right Click on your object, scroll down to 

assign a texture, either choose a created 

texture from the list or create a new one. 

 Select your object(s), open the Hypershade, 

right click on the texture/shader node and 

select assign material to selected. 

 
If you haven’t already got a texture assigned to your object, follow one of the above methods. 
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AH | Adding custom features to your Material 

Adding a custom image to a Material 

 Select lambert (or suitable alternative) > (Name it) > Colour □ > File 

 Select image 

 

 

 

 

 

 

 

 

Normal, Bump or Displacement Maps? 

A question that arises frequently as well as making regular appearances on forums; are the 

differences between each of these maps and how/when to use each of them. 

Bump Maps and Normal Maps do have their similarities in so far that neither of them affects 

geometry in a physical form however they do hold a vastly different amount of information and 

are used for a very different purpose. A Bump Map holds only single axis (height) information 

and will be used primarily to “shade” the surface and create the subtle feeling of depth. A 

Normal Map has the ability to hold information on all 3-axis allowing it to retain detail from 

higher mesh models to be latter recreated on lower geometric representations. Displacement 

Maps have a similar makeup to that of a Bump Map displaying a white to black colour range 

from 0-255 nevertheless their rendered results vary considerably. They do by all accounts rely 

heavily on near perfect UV’s as they affect the geometric position of vertices over the objects 

surface in relation to their value.  
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Mipmapping 

In this process (designed primarily for bitmaps) Maya stores a colour value for sequentially 

decreasing image sizes i.e. 1024 x 1024, 512 x 512, 256 x 256 and so on all the way down to 

1 x 1. Therefore during the rendering process the renderer determines the most appropriate 

mipmap for the relevant pixel, thus if the pixel is in the background a low resolution mipmap is 

used and vice versa. Maya can also use an average of two mipmaps for a more accurate 

representation of a pixel. Mipmapping is designed to reduce the rendering load as it will not 

have to filter through large image sizes to determine a specific pixels colour. 

Assigning a Bump Map 

 Select your existing material (i.e. lambert1) > Bump Mapping □ > File 

 Select image (Bump Map) 

 

Note: This image has been assigned 

a black and white chequered texture 

into the bump. Creating the feeling of 

depth that additional geometry wasn’t 

required to make. 

 

 

 

 

  



Chapter 3: Texturing 

Repeating Textures 

As the title suggests you can make a small material repeat over a larger area. For this to be 

effective it is advisable you use a seamless square texture, or learn how to create one yourself 

on page 118. 

Once you have your image file ready, create a Polygon Plane and stretch it out over your grid 

 Press 6 to go into shaded mode (this way you can see the changes) 

 Select your existing Material 

o Object > Material (i.e. Lambert1) 

o Window > Rendering Editors > Hypershade > Lambert1 

 Press the arrow going into the box either next to the material name or next to the colour 

(this will take you to your texture file) 

 Press the same arrow again next to the material name or on the tabs you will see a 

place2dTexture Tab 

 Repeat UV’s 

o 1x1 are the default settings 

o 2x2 = 4 instances of your image  

o 3x3 = 9 instance 

and so on… 

 Rotate Frame – If the image if it has come in a different way that what you have set up 

for your UV’s use this setting to correct the rotation. 
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AH | Texture Examples 

Mia_material_x is probably one of the most versatile textures within Maya and because of this 

we find ourselves using it a large proportion of the time as it’s easy to create anything from 

wood, metal or glass within a few simple steps. 

We will take you through a couple of them but will leave the remainder for you to play around 

with.    

Wooden Floor 

 Create a floor plane > RMB Click and Drag down to > Assign New Material  

 Select Mia_material_ x > (Name it…WoodenFloor) > Select Colour □ > File 

 Select wooden floor image (you had already prepared) 

 Drop Reflectivity down to around > 0.1- 0.2 

 Glossiness > 0.2 – 0.3 

Bump 

 Attribute Editor > Bump > Standard Bump □  

 Import file 

 Bump depth = 0.15 

More definition (points further away from the camera) 

 File attributes 

o Filter Type > Mipmap 

o Mental ray > Advanced Elliptical filtering 
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Glass Window 

We are going to create a very simple glasslike texture that we can apply to our window 

geometry. 

 Windows > Hypershade > Create > Mental Ray Materials > Mia_material_x 

 Add file texture colour (window) 

 Reflectivity = 0.3 

 Index of refraction = 0.8 

 Refraction Colour > add in same texture file as above 

Or  

 Windows > Hypershade > Create > Mental Ray Materials > Mia_material_x 

 Presets* > GlassThin > Replave 

 Add file texture to Diffuse Colour 

 

Note:  Useful to link to the same file rather than creating multiple instances of the same texture.  

 One quick way to “dirty up” the window would be to 

o Transparency > Chequered box > Noise/fractal/file(custom) 
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Glass - Whisky Tumbler (and contents) 

Create > Polygon > Polygon Cylinder  

 Subdivisiosn Axis 20 

 Subdivisions Height 5 

 Caps 2 

There are 4 rows of vertices in the middle of the tumbler. Switch 

to side view and out of those 4 select the bottom 3 rows of 

vertices and scale them in the Y Axis. Drop them to the bottom 

of the so they are close to the base and gradually scale them 

inward creating the curve at the bottom.   

Select the remaining row of Vertices and move them down to a height where you would like 

the glass to appear filled, (and tweak the glass height if required). 

Switch to top view (or perspective) and select the top inner edge (RMB 

> Edge > Double click one edge to select 

continuous edges) and scale them outward 

towards creating the glass thickness. Then 

select all the centre faces and Edit Mesh > 

Extrude switch to side view, hold down the “v” 

key and snap the extrude to the row of vertices that determines the fill 

level, press “g“ to repeat the extrude and bring the vertices down 

towards the bottom of the glass leaving a thick base.  

Switch to perspective view and select the faces below the fill line but 

not the base (you 

should have one row 

of faces selected at 

this point). Mesh > 

Extract will separate 

the geometry from the 

Tumbler, then move 

the geometry to one 

side.   
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Select the upper rim of edges Mesh > Fill hole 

then Edit > Delete by Type > History. Assign a 

mia_material_x and rename it to WhiskyLiquid 

(or similar), select the Presets* button and 

select GlassPhysical > Replace.  

Note: If the mental ray materials are not available in the 

Hypershade menu we need to make sure the 

mayatomr.mll plugin is loaded in the Plug-in Manager 

(Window > Settings/Preferences > Plug-in manager) 

 Refraction > Index of Refraction 0.8 -1 

 Advanced Refraction > Max Distance 15.0 

 Advanced Refraction  > Colour at Max Distance 

Chose liquid colour 

Put your liquid geometry back in place (zero out your translation 

attributes) then select the top face you created earlier by filling 

the hole. Mesh > Extract to separate the top face from your 

geometry and assign a mia_material_x and name it 

WhiskySurface. Select the Presets* button and select 

GlassPhysical > Replace.  

 Refraction > Index of Refraction 1.33 - 1.36 

 Advanced Refraction > Max Distance 15.0 

 Advanced Refraction > Colour at Max Distance Chose liquid colour. This works best 

with an exact match so if you just take the HSV values from your WhiskyLiquid texture 

this will be fine. 

Lastly, if you select your tumbler assign a mia_material_x and name it GlassTumbler. Select 

the Presets* button and select GlassThick  > Replace. 

Note: We need to ensure all normals (Display > Polygons > 

Face Normals) are facing outward to ensure the effects are 

calculated correctly. If not go to the Normals > Reverse 

option to flip them around. 
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We will not be delving into the render 

and lighting in too much detail, but in 

order for you to render this effect you 

need a light and some improvements 

from the base render settings. We 

will be using two of Mayas pre-sets. 

 Light: Physical sun and sky  

(Render Settings > Indirect 

Lighting > Environment > Physical Sun and Sky > Create) 

 Render settings: Quality > Quality Presets > Production  

Note: You can tweak the Max Distance settings in your liquid material to lighten and darken 

the appearance. 

Here is another example of the above technique within a finished scene. 
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AH | Mental Ray Presets 

(Top left to bottom right) Chrome, Copper, Frosted Glass, Glass Solid, Glass Thin, Ceramic, 

Glossy Plastic, Matte Plastic, Pearl, Rubber, Stained Metal, Translucent Plastic Film, Water, 

Car Paint Shader, Glass/Pearl (Preset Blend), Copper/Stained Metal (Preset Blend).  

AH | Image Optimisation 

Maya has its own proprietary image format that it likes to use, the *.iff format. Converting your 

files to this format will actually allow Maya to work more efficiently, thus speeding up render 

times. There are two main ways to convert images to .iff’s, Fcheck can save images out as 

.iff’s or you can download a plug-in for Photoshop from high-end 3D. 

Another useful way of speeding up Maya’s rendering is to set the texture filtering to ‘off’ or 

‘mip-map’. The texture filter is essentially a blur applied to smooth textures, but in large image 

files and heavy scenes in general this can substantially increase render times and memory 

load. Obviously there is a trade off in quality, but you will have to find what works best for your 

project. 
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PC | Subsurface Scatter Skin Material 

Amongst the Mental Ray materials that are built into Maya are a few subsurface scatter nodes. 

The one we will be using today is the misss_fast_skin_maya shader, which has a few extra 

options than the misss_fast_simple_maya shader to give us a really nice skin shader, really 

quickly. 

Open a new scene and let’s set up our rendering settings. First change the resolution so 

something more appropriate such as HD720, and then make sure we are using mental ray as 

our renderer. 

Note: If the mental ray option is not available in the drop 

down menu we need to make sure the mayatomr.mll plugin 

is loaded in the Plug-in Manager (Window > 

Settings/Preferences > Plug-in manager). 

In the Quality Tab we can 

use the preset Production 

to give us a good start on 

our settings, and for now 

we will just change the 

filter to Triangle to give us 

sharper edges and speed 

up rendering. 
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For the scene lighting I have used three point lights, a front light a side light and a back light. 

The side light I have reduced the intensity to 0.5, otherwise all settings are left at default. The 

models I have chosen to import for this tutorial are the ones we built in the modelling section 

earlier, the ear and the hand. These should give a good representation of how skin shaders 

will look on your own models. 

 

I have enabled ray-traced shadows on the 

front light with the following settings to 

give the scene some depth. 

If we hit render then, we should see 

something like this: 

You can see the influence of the soft 

shadows being created and we can also 

see a little of the backlight breaking across 

the edge of the hand. 
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Open your Hypershade window (Window 

> Rendering Editors > Hypershade) and 

in the search bar type “misss”. This will 

filter all of the subsurface scatter nodes. 

We are going to use the 

misss_fast_skin_maya node so click on 

that. (A node will appear in your 

materials window and Work Area). 

You will find that another node, the 

misss_fast_lmap_maya node has been 

automatically created and linked to the skin node for us. 

Select both of the objects and right click hold the skin shader and select Assign Material to 

Selection. You will most likely see the objects turn bright red, this is ok – it is because Maya’s 

viewport cannot render subsurface scattering. 

Render your scene. You can see that although the shading 

is nice, there is a long way to go to make it realistic. It is too 

pale and orange and not enough backlight is filtering 

through. 
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Double click on the material in the Hypershade to 

open the Attributes Editor and expand the 

Subsurface Scattering Layer panel. This is where 

most of our adjustment will come in. 

The Diffuse Layer carries the main colour attributes. 

The Epidermal Scatter is our primary focus, this is the 

colour of front light reflecting off the surface. 

The Subdermal is the ‘flesh’ part of our skin. 

Finally, the Back Scatter is the light passing in from 

behind, which is why we have the extra attribute 

Depth. This controls how far into a surface the light 

can penetrate. 

The Radius value controls how much the scatter will 

spread over our model and finally the Weight value 

controls how much influence each colour will have 

over our final skin material. 

The Diffuse colour is going to have very limited influence, 

change the value to 0.1 and change the Diffuse Color to a 

very light pinkish tone. 

The easiest way to see exactly what we are getting 

with each of the scatter colours is to work with them 

one at a time. Set the Scatter Weight for the 

Subdermal and Back Scatter attributes to zero. 

We will work on the Epidermal first. This is going to 

be our primary colour so set the Scatter Weight to 

one and The Scatter Radius is far too high so bring 

that down to about two. We should get a nice, lit 

skin colour coming from our model when we hit render. 
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For the Subdermal, (remember to set the Epidermal 

Weight back to zero first) we want a more pinkish ‘flesh’ 

colour and we don’t want the influence to be too high, a 

Scatter Weight of about 0.5 should suffice. We will set the 

Scatter Radius to two again. 

 

For our Back Scatter colour we can keep the deep red 

colour and set the Scatter Weight to one. We want a 

slightly wider Scatter Radius somewhere around five and 

the Scatter Depth Value depends on your scene and 

model scale, for me a value of two is sufficient. You can 

see that especially the thin tip of the ear, the red comes 

straight through, and on the hand the edges are 

highlighted. 

Finally, we want to combine these settings. Set the 

Epidermal Weight to 0.8, the Subdermal Weight to 0.5 and 

the Back Scatter Weight to one and hit render. 

Now we have a simple skin material that you can 

customise and tweak for your own specific needs. 
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PC | Toon Shading 

There are two main components to toon shading; on the one hand there is the flat shading 

itself and on the other there is the solid outline on the objects themselves. For this tutorial we 

are going to focus on the two tone shader. 

Create a point light and a few objects in the 

viewport. With one of the objects selected, 

and in the Rendering menu set, click on Toon 

> Assign Fill Shader > Light Angle Two Tone.  

The attribute Editor will open with a focus on a newly created 

lightAngleShader. If you render the scene you will see the 

shader at work, splitting objects into two clean shades of grey. 

To build an outline around 

the shapes, select all the 

objects and select Toon > 

Assign Outline > Add New 

Toon Outline.  
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This will create a new paint effects shape around the outline of the shape and also against 

any sharp edges. In some cases (for example when rounded surfaces come to a point) you 

may get a more accurate result if you set Profile Line’ to Offset Mesh. 

Experiment with the options and 

ramps in the lightAngleShader to get 

your desired effect. 
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AH | Photoshop Basics 

Introduction  

Photoshop is a powerful image editing application that provides industry standard versatility 

and optimised tool sets allowing for the creation of professional and sophisticated images. 

Many animation books can often take for granted an understanding of Photoshop, but we 

know from experience many people do not always have this knowledge. So as oppose to you 

having to search for further tutorials we have dedicated this section to go over the basics of 

Photoshop and its uses within Maya.  

Photoshop Layout  

 

 

 

 

 

 

 

 

 

 

1. Main menu bar 

2. Additional views and Bridging options 

3. Zoom and image pane options 

4. Pre-configured Menu-sets for appropriate design stages 

5. Colours / Styles / Swatches options (all dependent on Menu-sets). 

6. Adjustment masks / Fonts / Brushes (all dependent on Menu-sets). 

7. Layers Menu, with appropriate tools 

8. Currently selected tool and further options 

9. Tool shelf 

10. Colour selection pallet 

11. Workspace 
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Photoshop Toolset 

Move Tool (V) – Moves Selections and layers 

Rectangular Marquee Selection Tool (M) – rectangular selections 

Lasso Tool (L) – Freehand selection 

Magic Wand Tool (W) - Selects similarly colours regions 

Crop (C) – Reduced image size within selected region 

Eyedropper Tool (I) – Samples the selected colour 

Spot Healing Brush (J) – Automatically removes blemishes 

Brush Tool (B) – Freehand paintbrush tool 

Stamp (S) – Will clone a selected area to another 

History Brush (Y) 

Eraser (E) – Removes content 

Paint Bucket Tool (G) – Flood fill 

Blur – Spreads pixels within selection 

Burn (O) – Freehand tool that darkens an area 

Pen Tool (P) – Draws paths consisting of Bezier curves  

Horizontal Type Tool (T) – Text tool 

Path Selection Tool (A)–Selects & moves fragments of existing paths 

Custom Shape Tool (U) – Allows the creation of custom shapes 

Object Rotation Tool (K) – Rotates a 3D object 

Camera Rotate Tool (N) – Rotates a camera in a 3D scene 

Hand Tool (H) – Allows the navigation of a zoomed image 

Zoom (Z) – Enlarges the canvas 

Switch Foreground / Background Colours 
 

Foreground and Background Colour 

Edit in Quick Mask Mode – useful for selecting large areas quickly 

 

All icons that have a small arrow in the bottom right hand corner indicate there are further tool 

options available within that specific tool set. 
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Mouse vs. Tablet 

Can you do everything a tablet does on a mouse? Almost, the tablet however has the 

fundamental advantage of being able to use the pressure sensitivity attribute enabling you to 

taper off lines and blend colours more subtly. Similar effects can be obtained with a mouse 

combined with Photoshop features but as you all know a mouse click is either on or off, there 

is no in-between, you will have to put in a lot more work to attain similar effects to that of a 

tablet. In today's market you don't have to spend a fortune on a tablet but we would 

recommend getting one if you are interested in creating your own textures. 

The Colour Palette 

To Save a Colour to the Palette 

 Open the swatches tab 

 Select the paint bucket tool 

 Left click within the swatches tab 

 Save colour, naming it accordingly 

Brushes 

Editing a Brush 

You may need to edit the appearance of a brush to get the desired effect needed for your 

texture. By default brushes are usually solid, uniformed and repetitive almost the opposite of 

what we want at this point. Therefore to break up the brush's continuity follow the below 

instructions. 

 

 Choose an appropriate colour  

 Select a default brush that will suit your requirements 

 Go into the brush window Window > Brushes (F5) 

 Edit all or some of the following characteristics at your discretion.  

1. Brush Tip Shape > Spacing: Use the slider to separate the brush strokes so 

there is a gap between each one. 

2. Shape Dynamics > Size Jitter: Slide to randomise the sizes and/or use the 

dropdown menu (if you're using a tablet) to link this attribute to pen pressure. 

3. Scattering > Scatter: Slide to randomise the positioning of the brush strokes. 

4. Size it to a reasonable scale. 

5. Plus any other adjustments you feel are necessary. 
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Creating a New Custom Brush 

Under some circumstances you may require a brush to create a unique or repetitive shape for 

uses like adding blemishes. To create a custom brush:  

 File > New 

 50px by 50px workspace area, ensure you have a transparent background 

 Locate a brush to give you a starting point (optional) 

 Create your brush using the relevant tools. 

 Select > All 

 Edit > Define brush Preset 

 Chose a name for your brush, once saved it will appear in the brushes pallet  

 

Photoshop and Maya 

Photoshop can save in a variety of image formats all of which Maya can recognise pushing 

these two programs to become widely recognised as industry standards. There are however 

a few issues when using PSD files as textures within Maya that you are wise to take note of. 

They become apparent when using standard methods of layer blending and layer opacity.  
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AH | Preparing image planes for use in Maya 

The first stage is to get all your images onto one canvas (if 

they are not already). To do this navigate to File > Open 

then locate your appropriate files and open them, once you 

have done this repeatedly (dependent on how many 

images you have) you will have tabs at the top of your 

screen each with a perspective shot of your model.  

Note: To bring a tab out into a separate menu, just LMB click 

and drag onto the workspace. 

For this example I will work in different panes, but you may find 

it easier to keep them in tab format. 

 

 

 

 

 

 

 

 

 

 

 

We now have our 4 separate images that we need to bring into one, but we need to ensure 

that the canvas we create will be of sufficient size to hold our complete image. Select a tab or 

a window, and navigate to Image > Canvas Size and click the option you will be presented 

with the size of the image, at his point make a mental note or write down the dimensions. The 

top of my car is approximately 24cm x 12cm (w x h), and the front of my car is approximately 

11cm x 9cm. On a quick calculation we need a canvas at least 33cm x 35cm to house our 

images, so to give us some manoeuvrability we’ll round it up to 40cm x 40cm. 
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File > New and you will be presented with 

the following box. Fill in your required 

fields (40x40) ensuring the measurement 

in the right hand column is in centimetres. 

Give your file a name (at the top) then click 

OK. 

Now open one of your existing tabs or 

windows that has one of your perspective 

views within it, and navigate to Select > All (ctrl-a).  

A dotted line will have appeared around the edge at 

this point which means your image is selected. 

Navigate to Edit > Copy (ctrl-c) then open your newly 

created blank 40x40 canvas and select Edit > Paste 

(ctrl-z). You should then have something that looks like the below screen. 

 

 

 

 

 

 

 

 

 

We’ve highlighted 3 points that might be of interest for you at this point: 

1. Zoom menu – if your workspace looks unusually large or small, resize is using a 

percentage scale. 

2. Also a zoom menu (as above). 

3. Layers Menu – you will notice you now have two layers, one most probably stating 

background with a padlock and the other saying layer 1. 

  



Chapter 3: Texturing 

Photoshop Layers: 

As you would expect; layers allow you to isolate items separately allowing you to manipulate 

or alter them in ways that will not affect the remainder of the canvas. Once you have a layer 

selected any alterations will only affect that layer and no other, if at this point you want to 

reposition your layer, ensure its selected, click the Move Tool (v), top icon LHS, then click and 

drag accordingly. You may have also noticed an eye on the LHS of each layer, by clicking this 

you will toggle the layers visibility on/off. 

You now need to repeat the process three more times until all your perspective images are 

situated within the same canvas. You should then be presented with something that looks like 

this. 

 

 

 

 

 

 

 

 

You may notice our layers now have names, so to add layer name firstly you can either select 

the layer RMB click > Layer Properties which will enable you to rename (and colour code, 

which we will not be using) or double click on the text itself where it says the layer name, being 

careful at this point to only click the layer name as double clicking the layer itself will open the 

Layer Style Menu, which at this point we will also not be using. We altered the dropdown 

option under where it says layers (default to Normal), to Darker Colour. The reason being it 

removes the white background from each image so if we move them closer together one of 

them will not disappear. 

 

At this point I would recommend experimenting with the overlap options, highlight one of your 

images temporarily place it on top of another and filter through the dropdown menu to see the 

effect. 
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The next stage is to add in some guide lines that allow us to match up our image perspectives 

in order to provide us with the most accurate scale possible. To do this ensure the rulers are 

being displayed around the border of your work area, if they are not go to View > Rulers (ctrl-

r). To create the light blue ruler lines you see on the image below, click on the white ruler 

section that surrounds the canvas and 

simply drag them onto your image, 

(vice versa to remove) and position 

them in such a way so you can 

determine if their scale matches 

or whether they need adjusting. 

If the image needs adjusting 

select the appropriate layer and 

either navigate to Edit > Transform and 

select the appropriate modification tool: 

 Scale 

 Rotate 

 Skew  

 Distort 

 Perspective 

 Warp 

Or use Edit > Free Transform (ctrl-t) and you will be able to manipulate it accordingly, 

if you want to scale in proportion ensure you’re holding shift and if you want to skew 

hold Ctrl. 

Note: If you make an error in Photoshop, to step back one process 

its ctrl-z, to continue stepping backward you need to press ctrl-alt-z. 

Once you have your images lined up as above its important to check 

that the width of the top correlates with that of the front/rear. A few 

ways to do this would be to rotate one of them 90° and see if it’s within the margins. 

Another way is to navigate to Window > Measurement Log then select the ruler tool 

(click and hold on the eyedropper tool to be able to select).  

Then with this tool selected you can click on the guidelines one at a time and with the 

measurement log open click Record Measurements. Our measurements are 4pixels apart 

which we can live with. 
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The final preparation stage is to save out the re-sized images back to singular files. There are 

a few ways to do this, the first of which is being to select the Rectangular Marquee Tool (by 

default it will snap to the ruled lines when in the vicinity) and highlight the image, copy the 

selection (ctrl-c) then going to File > New Photoshop’s default sizing’s in the box at this time 

will be the exact same as the copied image, so by clicking OK and then pasting (ctrl-v) the 

image it will fit perfectly. If you want to increase the canvas size to a whole number i.e. 8cm x 

12cm for easy referencing navigate to Image > Canvas Size (this doesn’t alter the image size 

whatsoever), save the file to complete. 
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When you get to the rear image (as it hasn’t got guide all around) the car, to keep correlation 

with the front I hide/remove the front layer and fit the image between its guidelines this way 

you know it will be the exact same size. 

The second option uses a similar selection technique but with the cropping tool instead. Once 

the image is highlighted double click within the selection and everything will disappear. Save 

the image then press ctrl-alt-z until you’re presented with your full image again and repeat. 

Typical naming convention “Car_Top”. 

 

 

 

 

 

 

 
 
 
 

  



Chapter 3: Texturing 

AH | Colour Matching 

There will be times when you like the design or print of one image but prefer the colour of 

another; in this section we will show you how to overcome this problem with various 

techniques.  

Match Colour 

1) Open both your files in Photoshop. For all intents and purposes I’m going to say that I 

prefer the grain on the left image but the colour of the one on the right. 

 

 

 

 

 

 

 

 

 

 

Note: for reference purposes you may wish to create a duplicate layer before continuing. 
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2) (Optional step – completed in 

demonstration) Click on the left 

image and desaturate (remove all 

colour) Image > Adjustments > 

Hue/Saturation (Ctrl+U), drag the 

saturation slider all the way to the 

left (-100). You will then be left 

with a greyscale image. 

3) (Optional step – not completed in 

demonstration) Blur the colour you 

intend to match, select the file (in our case it would be the one on the right), navigate 

to Filter > Blur > Gaussian Blur (transition sliders accordingly). 

4) The next stage is to navigate to Image > Adjustments > Match Colour… The ‘Match 

Colour’ dialogue box will appear and you will need to select the source at the bottom 

before you can adjust the values. The source will be the other file you opened at the 

beginning and you can specify a layer if you wish. Once the source has been selected 

(Colour.psd in our case) you can then use the sliders to create the image tone that you 

require, once finished click OK.  
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Occasionally on aspects such as wooden floors the divisions between them may require re-

emphasising after the merge, to do this select Filter > Sharpen > Smart Sharpen and alter the 

sliders until the desired end effect is achieved. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

As you can see it creates a nice colour merge between the two textures, resulting in a 

professional and realistic alternate wood effect. 
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Ah | Seamless Texture Creation 

In this section we will take you through the process of creating a texture that can be repeated 

seamlessly, and reducing any repeating patterns that may arise. Bricks are a little more 

challenging than say a wooden floor but the processes involved are identical. 

 

Step 1: Importing into Photoshop  

Locate the file and import this into Photoshop, it makes for 

good practice that texture images are square and our 

preferred size is 1024 x 1024. When re-sizing an image try to 

make a little less work for yourself by not having half / quarter 

bricks visible on top and bottom, try to keep them whole, this 

isn’t essential but a good practice. 

 

Step 2: Offsetting the Image 

Once the file is within Photoshop (as sized 

accordingly) navigate to Filter > Other > 

Offset. Offset both approximately 50% 

(512 pixels) and generally at this stage you 

will have the appearance of a cross in the 

centre of your image 

 

Step 3: Seam Removal 

The next step is to use the clone stamp at 

100% with feathered edges to remove the 

sharp visible seams both horizontally and 

vertically. To use this tool select an appropriate brush size (50-70px), hover over an area that 

you would like the clone to commence (usually something in the general vicinity is best suited 

as colours are often similar) hold Alt-LMB. This gives the starting point for the clone, then 

when you hover with your mouse curser you will see a preview of the stamp within the circular 

boundary of your curser. The tool moves in accordance to your mouse navigation so if this is 

your first time using the tool it may take some getting used to. 
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Step 4: Tidying up the texture 

You will then most probably need 

to tidy things up a little, whilst also 

noticing that the horizontal line is 

not as visible as the vertical as we 

cropped this earlier at a suitable 

point. The majority of the initial 

work outlay it best carried out with 

the clone stamp with no opacity 

applied. Below we hoped to 

illustrate the ideology behind this 

process by paying particular 

attention to duplicating the 

corners and edges of similarly 

sized bricks we are able to help 

mask the seam down the centre. 

Continue defining the 

corners and edges, 

and using random 

brick features to define 

and distinguish others. 

You may find at times 

sections become 

blurred, to counteract 

this once you have 

found the feature you 

want to replicate, click 

in the same place 

repeatedly to apply the 

stamp more visibly. If 

as well keep referring 

back to the same 

sections or can still see 

the seams etc., the 

easiest thing to do is jump back to step 2, (offsetting the image for a second time using 

different numbers), then continuing with the above process. 
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Step 5: Checking Seams / Enlarging the Image 

The next step you can see if what you have 

done makes for a seamless texture. Create a 

blank canvas 2048 x 2048 and past in your 

image 4 times and position appropriately, from 

all accounts we have achieved a seamless 

texture but the only thing is the human brain is 

exceptionally good at recognising patterns, so 

if this is to be spread over a large area without 

additional props you may want to look into 

disguising these “repeating attributes”. We’ve 

highlighted a few obvious ones, which will 

always generally include a distinguishable 

brick pattern, some shading and a brink that simply stands out from the rest of them. 
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Whether you want to stick with the larger image or refer back to the previous one the general 

processes will be the same.  

 To lighten your dark spots use the dodge tool on a low (5%) exposure until satisfactory. 

 If using the large image take out the key repeating features, colour some of the bricks 

and alter their appearance using techniques from earlier steps to give a truly authentic 

feel.  

The above image has had “arguably” the most distinguishable repeating features 

removed/disguised. The process can take a little bit of time in the early days but you’ll quickly 

adhere to the tools and techniques if done regularly. 

You can of course advance on these textures as you see fit, however once you have finished 

tweaking or if you decide to perform tasks such as colour matching, just ensure you offset the 
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UV’s to check no seams have been re- created, (if visible they should only be slight and at this 

stage it shouldn’t take long to rectify) 

 


